package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([0-9]+) X,)?(?: )?(?:([0-9]+) Y,)?(?: Z)?$`)
var str = `66 X, 55 Y, Z
66 X, 55 Y,
66 X, Z
55 Y, Z
66 X,
55 Y,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}