#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)"
Local $sString = "Usage:" & @CRLF & _
" diagrammer [--debug] [--output=<file>] <input-file>" & @CRLF & _
" diagrammer --help" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Options:" & @CRLF & _
" --debug, -d Draw the diagram upon a grid." & @CRLF & _
"" & @CRLF & _
" --help Show this message and exit." & @CRLF & _
"" & @CRLF & _
" --output=<file> Place output in file 'file'. [default: output.png]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Copyright Evgeny Gagauz, 2016." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")