const regex = /(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\n)([^\\n]*options:[^\\n]*(?=\\n?)(?:\\n+[ \\t].*?(?=\\n|$))*)', 'i')
const str = `Usage:
diagrammer [--debug] [--output=<file>] <input-file>
diagrammer --help
Options:
--debug, -d Draw the diagram upon a grid.
--help Show this message and exit.
--output=<file> Place output in file 'file'. [default: output.png]
Copyright Evgeny Gagauz, 2016.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}