import Foundation
let pattern = #"(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Usage:
diagrammer [--debug] [--output=<file>] <input-file>
diagrammer --help
Options:
--debug, -d Draw the diagram upon a grid.
--help Show this message and exit.
--output=<file> Place output in file 'file'. [default: output.png]
Copyright Evgeny Gagauz, 2016.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}