Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\b(0*(25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(0*(25[0-5]|2[0-4]\d|[01]?\d\d?))\b
/
gm
Test String
New
1.1.1.1 2.2.2.2 10.10.10.10 100.100.100.100 125.125.125.125 250.250.250.250 255.255.255.255 0101.0101.0101.0101 00000102.00000102.00000102.00000102 0.0.0.0 256.256.256.256 1234.1234.1234.1234