$re = '/([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)/';
$str = '<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>';
$subst = "\2\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;