// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)").unwrap();
let string = "<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>";
let substitution = "\\2\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}