import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?=.*[1-9])\\d*(?:\\.\\d{1,2})?\\s*";
final String string = "3\n"
+ "999\n"
+ "-3\n"
+ "0\n"
+ "0.0\n"
+ "1.0\n"
+ "0.1\n"
+ ".01\n"
+ "-0.0000000000000000000000000000000001\n"
+ "2e3\n"
+ "-2e3\n"
+ "2e-3\n"
+ "-2e-3\n"
+ "1.0e0\n"
+ "0.1e1\n"
+ ".01e-1\n"
+ "0.1\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}