package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/example\.com\/\w+\/?$`)
var str = `http://example.com/something
http://example.com/foo
http://example.com/foo/
http://example.com
http://example.com/
http://example.com/something/else
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}