import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/example\\.com\\/\\w+\\/?$";
final String string = "http://example.com/something\n"
+ "http://example.com/foo\n"
+ "http://example.com/foo/\n\n\n\n"
+ "http://example.com\n"
+ "http://example.com/\n"
+ "http://example.com/something/else\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}