package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[URL[^]]+\](?P<name>[^\[]+)\[\/URL\]`)
var str = `[URL="http://google.com"]ANY THING[/URL]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}