$re = '/\[URL[^]]+\](?P<name>[^\[]+)\[\/URL\]/';
$str = '[URL="http://google.com"]ANY THING[/URL]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);