re = /\[URL(?:\=\"(?P<url>[^"]+)\")?\](?P<name>[^\[]+)\[\/URL\]/
str = '[URL="http://google.com"]ANY THING[/URL]
[URL]ANY THING[/URL]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end