package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>([^<]+)<(?:br|p)>`)
var str = `<r> this is text which I do not want <a> This is what I want!<br>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}