re = /%{(.*?)}(?=[^{}]*%{|$)/m
str = 'Hello %{{{friends}} and foes}, I am here to %{cause problems with my \'}\'s}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end