$re = '/(?<!\d)(19[789]\d|20[012]\d)(?!\d)/m';
$str = '2020 aaaa1928bbbb aaaa1978bbbb 2019 2017345 1000 1999 1987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);