# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([^\]]+)"
test_str = ("#start gene g1\n"
"dog1\n"
"dog2\n"
"dog3\n"
"#protein sequence = [DDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD]\n"
"#end gene g1\n"
"###\n"
"#start gene g2\n"
"cat1\n"
"cat2\n"
"cat3\n"
"#protein sequence = [CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC\n"
"#CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC]\n"
"#end gene g2\n"
"###\n"
"#start gene g3\n"
"pig1\n"
"pig2\n"
"pig3")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.