# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)\d+(?:\/\d+)+(?!\S)(*SKIP)(*F)|[\/\\_\s]+/\n/gm;t' <<< "925/123 Black/Jack"