re = /(?<!\S)\d+(?:\/\d+)+(?!\S)(*SKIP)(*F)|[\/\\_\s]+/m
str = '925/123 Black/Jack'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result