const regex = /^(\d{1,2})(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,2})(\\d{2})', 'gm')
const str = `1430
1230a
1230am
430a`;
const subst = `$1:$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);