$re = '/(?<type>[^\s]+)\s(?<name>[^\s]+)(?=\s\{get;)/';
$str = 'public class User
{
//Some code here
}
public class Cars
{
public string Brand {get; set;}
public string YearModel {get; set;}
public List<User> HasRented {get; set;}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);