re = /(?<type>[^\s]+)\s(?<name>[^\s]+)(?=\s\{get;)/
str = 'public class User
{
//Some code here
}
public class Cars
{
public string Brand {get; set;}
public string YearModel {get; set;}
public List<User> HasRented {get; set;}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end