package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a.+?<\/a>`)
var str = `<b>http://url.com</b>
Use this for the negative lookahead? - <a.+?<\/a>
Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...
http://url.com http://url.com
gubergren, no sea http://url.com
<a href="http://url.com">
http://url.com
</a>
http://url.com <a href="http://url.com">http://url.com</a> http://url.com
http://url.com<a href="http://url.com"><b>http://url.com</b></a>http://url.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}