$re = '/(stxt|city):([^,\n]+)/m';
$str = 'stxt:usa,city:14
stxt:usa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);