package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([a-zA-Z]{2})\/([a-zA-Z]{1,10})(\/.*$)`)
var str = `/it/xyz/test/param+1/param-2/1234/gfd4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}