#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*color: (\"|\'|).*(\"|\'|)"
Local $sString = " color: "red"" & @CRLF & _
" color: 'red'" & @CRLF & _
" color: red" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# hoping to do this:" & @CRLF & _
"" & @CRLF & _
"match all 3 lines above and be able to replace any instance of the word red" & @CRLF & _
"with my own custom string"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")