package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*color: (\"|\'|).*(\"|\'|)`)
var str = ` color: "red"
color: 'red'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}