$re = '/^\s*color: (\"|\'|).*(\"|\'|)/';
$str = ' color: "red"
color: \'red\'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);