re = /^\s*color: (\"|\'|).*(\"|\'|)/
str = ' color: "red"
color: \'red\'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string'
# Print the match result
str.match(re) do |match|
puts match.to_s
end