import Foundation
let pattern = #"^\s*color: (\"|\'|).*(\"|\'|)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
color: "red"
color: 'red'
color: red
# hoping to do this:
match all 3 lines above and be able to replace any instance of the word red
with my own custom string
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}