import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Sample2).*(\\d{2}-\\d{2}-\\d{4}).*(?<=[a-z]_)(\\d+)(?=_\\d+).*(?<=_)(\\d+)$";
final String string = "Sample1_Sample2_1_05-11-2015_0_Sample3-AB_C_D_045_4_Sample4_123456";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}