using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[A-Z_]+$).*?_QPSK.*?_(SK)";
string input = @"FOO_QPSK_SK_BAR
FOO_QPSK_BLA_SK_BAR
FOO_QPcSK_SK_BAR
FOO_RQPSK_BLA_SK_BAR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}