import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span.*?(?:itemprop\\s*=\\s*\"\\s*name\\s*\"\\s*)?class\\s*=\\s*\"\\s*itemprop\\s*\"\\s*(?:itemprop\\s*=\\s*\"\\s*name\\s*\"\\s*)?>(.*?)<\\/span>";
final String string = " <div class=\"txt-block\" itemprop=\"contractors\" itemscope\n"
+ " itemtype=\"home\"> \n"
+ " <h4 class=\"inline\">Employs:</h4> <a href=\"/.../\" itemprop='url'><span class=\"itemprop\"\n"
+ " itemprop=\"name\">Carp 1</span></a>, <a href=\"/.../\"\n"
+ " itemprop='url'><span class=\"itemprop\" itemprop=\"name\">Carp\n"
+ " 2</span></a>, <a href=\"/.../\" itemprop='url'><span class=\"itemprop\"\n"
+ " itemprop=\"name\">Carp 3</span></a> <span\n"
+ " class=\"tots\">|</span>\n"
+ " <span class=\"see-more inline\"> <a href=\"/.../\" itemprop='url'>See full options</a> \n"
+ " </span>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}