using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d\D*){6}$";
string input = @"1 23456
1 2 3456
1 2 3 456
1 2 3 4 56
1 2 3 4 5 6
1 2 3 4 5 6 7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}