// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d\D*){6}$").unwrap();
let string = "1 23456
1 2 3456
1 2 3 456
1 2 3 4 56
1 2 3 4 5 6
1 2 3 4 5 6 7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}