$re = '/\[\/?(?:b|i|u|sup|url|image|color|size|font){1,}.*?]/mi';
$str = 'Test
Te[b]st[/b]
Tes[font]t[/font]
Test[Custom]Oh no![/Custom]
Test[color=red]With attr[/b][/i][/u][/color]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);