$re = '/^(?:[0-9]{1,3}\.){3}[0-9]{1,3}$/';
$str = '255.255.255.2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);