using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<id>(.+?)</id>$";
string input = @"<id>0000</id>
<song>Song 1</song>
<id>1111</id>
<song>Song 2</song>
<id>2222</id>
<song>Song 3</song>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}