Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^([a-z-]+|[\w]+)\.(((?!\.s1).+\.)?(co1|az1|ut1|eng|au1)\.(qprod|qops)\.net)$
"
gm
Input 1
1
New
test-app.az1.qprod.net jwm12535.s1.az1.qprod.net testing2.eng.qops.net kvm1.c1.co1.qprod.net bs1.co1.qprod.net staging.s1.co1.qprod.net staging.co1.qprod.net server.s1.co1.qprod.net s1.co1.qprod.net server2.co1.qprod.net s.co1.qprod.net testing.az1.qprod.net something1.eng.qops.net