#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^(?:[^,]*,){8}(.*),[^,]*,[^,]*$"
Local $sString = " ###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH**,**BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
"BLAHBLAH, BLAHBLAH," & @CRLF & _
"BLAHBLAH, BLAHBLAH," & @CRLF & _
"BLAHBLAH," & @CRLF & _
""BLAHBLAH"""**,**E," & @CRLF & _
"###"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")