re = /^(?:[^,]*,){8}(.*),[^,]*,[^,]*$/
str = ' ###BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH,BLAHBLAH**,**BLAHBLAH,
BLAHBLAH,
BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH, BLAHBLAH,
BLAHBLAH,
"BLAHBLAH"""**,**E,
###'
# Print the match result
str.match(re) do |match|
puts match.to_s
end