import Foundation
let pattern = #"(?<=^፻.+)\b(\w)(?=.*፻$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
፻this test works፻
፻this test does not work፻
this is a line that stays unchanged
this is a line that stays unchanged፻
፻this is a line that stays unchanged
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"፻$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)