$re = '/robert ((?:(?!palmer).)+?) palmer sent for the boat/m';
$str = 'Match
robert eric palmer sent for the boat
robert eric william palmer sent for the boat
No match
robert eric palmer palmer sent for the boat
robert eric william palmer palmer sent for the boat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);