package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{5})\D{0,3}(\d{4})$`)
var str = `43234-3423`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}