#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)"
Local $sString = "<table style="background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;" width="772">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")