using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"background\-image:(?: {1,}|)url(?: {1,}|)\(['|""](.*)['|""]\)";
string input = @"<table style=""background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;"" width=""772"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}