import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"#(!->|->|!)*(\w|\')+(?![^<]*[]>|[^<>]*<\/)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<p>Hello</p>
<p>world</p>
<p>jjejejejjeje</p>
#->allo
<code>#un_lien_ignore jgeijdejdehdej et #un_autre pis celui là! egalement #!ignore_moi</code>
<a href="ceci nes pas un tag">li</a><a href="ceci n'est #pas un tag">li</a>
mais #->moi_j'en_suis_un #!important_avec_un_lien
<span>
#!pasmoi
#->moisnon
#->pasoim
#->lol
</span>
[->]
[->][->][->][->][->]
[<-][<-][<-][<-][<-][<-][<-][<-]
[->][->][->][->][->]
[->][->][->][->][->]
#lien
#des_tags encore #école #stratégie
[->][->][->][->][->]
[->][->][->][->][->] et et encore #->avec un lien et #sans_lien chose qui devrait # !matcher encore #un_tag et un #autre_avec_un_lien
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)