import re
regex = re.compile(r"\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d", flags=re.MULTILINE)
test_str = ("Number to call (514) 723-4383\n"
"The office number is 432-763-3456\n"
"call 643 771-4453 tomorrow.\n"
"Jack's number is (765) 452/1243.\n"
"The central number is 871/445/6197\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")