#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=Param\(\s*\1|)(\[\w*\])"
Local $sString = "[cmdletbinding()]" & @CRLF & _
"Param(" & @CRLF & _
" [STRING]$CustomerName," & @CRLF & _
" [STRING]$ClusterName," & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"[STRING]$CustomerName," & @CRLF & _
"[STRING]$ClusterName," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")