const regex = /(-|\*|[0-9]+.) \[ \]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-|\\*|[0-9]+.) \\[ \\]', 'g')
const str = `- [ ]
-[]
- []
-[x]
- [X]
1. [ ]
2. [x]
11. []
2125. [ ]
. [ ] // Fixed with + instead of *
1. [ ] #TODO #experiments **Zephyr** Use external Groove:
1. [ ] Board LED turning on.
2. [ ] Buzzer making sound.
3. [ ] Neo Pixel LED turning on with rainbow pattern.
4. [ ] Neo Pixel LED switching on/off state.
5. [ ] Neo Pixel LED switching different patterns.
6. [ ] OLED screen showing some text.
7. [ ] OLED screen showing some images.
8. [ ] Combination of 2
9. [ ] Combination of all!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}